Strange error in compiling .pdf

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Strange error in compiling .pdf

aiyoung
Hello All,

I am trying to get a .cls that my university provides to place nice with LyX.

I followed the instructions found on this site: http://blog.icall-research.net/2011/01/07/latex-adding-a-custom-class-in-lyx-1-6-8-for-mac-os/ to have the .cls avalible to LyX.

In addition to the above, i added the .clo file so that i could use the preview function in LyX.

I then imported the .tex example template (which compiles into a .pdf just fine in TeXworks) into LyX.

When i click on view in LyX, i receive the following error:


Undefined Control Sequence:

 \maketitle
               
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.


By exporting the LyX file back into a .tex file, i found that i would get the same error when i tried previewing the .pdf in TeXworks!

I traced the issue to LyX adding \maketitle in the wrong spot by comparing the .tex file LyX produced with the original .tex template.

When i move \maketitle to match the original .tex template, the file compiles correctly in TeXworks.

I then proceeded to save this new .tex file and then import the file into LyX to see if LyX would now preview the .pdf correctly.

To my dismay, LyX moved the \maketitle to the incorrect spot again!

If any LyX user has run into this issue when adding a .cls file to LyX and has any ideas on how i can get the .pdf preview to work correctly, I'd appreciate any help i can get.

I would much rather work on my thesis in LyX than have to switch to a different LaTeX editor.
Loading...