After updating packages in MikTex, several problems appeared. In textclass.lst all classes are marked as "false".

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

After updating packages in MikTex, several problems appeared. In textclass.lst all classes are marked as "false".

santcas20
Hi,

I had a good working installation of Lyx 2.0.1 with MikTex 2.8.
I decided to install a new package in MikteX today and then run an update using the Package Manager.
Several packages were updated, to their latest versions. Apparently they were all from 2009.

When I opened LyX again, it complained that the book-komascript class was not available anymore.
I checked the document classes in settings, and none of the document classes were available.
He was also asking me for a lot of packages on the fly, that he updated successfully.

But then I also had this problem, that I posted here:
http://tex.stackexchange.com/questions/104046/help-after-updating-my-packages-with-miktex-i-cannot-compile-in-lyx
Lyx was looking for a file:
dehypht-x-2009-06-19.tex

referenced to 2009, but since the file date changed to 2012, it was not recognizable.

I solved that using:
http://sourceforge.net/p/miktex/bugs/2034/?page=0 

Practically in MikTex I just updated the FNDB in MikTeX as an admin and as a normal user. This solved the bug.

The I tried Tools->Reconfigure again, but it still does not recognize the book-komascript.
I tried the solutions posted here:
http://lyx.475766.n2.nabble.com/quot-Document-Class-not-Available-quot-error-message-td480879.html

But it also doesn't work.
This is the log file:
configure.log

This is the textclass.lst file:textclass.lst

I also tried everything in this page:
http://wiki.lyx.org/FAQ/LaTeXErrors#missing-class

But nothing works!

I installed now Lyx version 2.0.5 and it also doesn't work there!!

What can I do?




Loading...